在通过composer升级Magento2.x的时候遇到的这个问题(该服务器下第一次升级,因为第一次的时候会有提示让你保存相关用户名和密码),如果你输入了不正确的用户名和密码就会提示“Invalid credentials for ‘https://repo.magento.com/packages.json’, aborting.”这个错误。

问题的根本在于这个用户名和密码是什么?

此处的用户名应该使用公钥“Public Key”,密码则是私钥“Private Key”,那这个公钥和私钥应该从哪里获取呢?可以通过

https://www.magentocommerce.com/magento-connect/customer/account/

Invalid credentials for 'https://repo.magento.com/packages.json', aborting.

输入后,会提示你是否保存该授权信息,保存之后再通过composer进行升级的时候就不会提示该问题了。

0 人喜欢
51 人查阅

你可能对下面的文章也感兴趣...

Magento是专业的,也是业界评价最高的商城解决方案,Magento也会不时的推出些漏洞的补丁,这也是开源软件无与伦比的优点,对于商城网站来说及时的打上这些漏洞的补丁显得异常重要,本文曹晓涛就跟大家一起研究下Magento的补丁应该如何打。
Read More
在Magento1.9.2 Connect Manager点击Check for Updates来检测Magento需要升级的模块时没有反应,这样自然也就无法通过Connect Manager来升级。如果你是通过曹晓涛前面介绍的通过SSH命令来升级Magento的话,你就可以看到具体的错误提示“Magento Downloader 1.9.2 unknown cipher list”。这个主要是因为Magento基于安全因素的考虑,对代码进行了很多调整,而且这些还需要CentOS服务器来支持。
Read More

现在才 1 条评论,快来抢地盘吧!

你有什么想法,说出来我们才能知道!

请填写您的姓名. 请填写有效的电子邮箱. 请输入评论内容.